Sofort phone lines are down
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Feb 28, 2020 - 17:00 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 28, 2020 - 16:15 CET
Investigating
Merchants and Customers in EU region are currently experiencing difficulties reaching Sofort via phone. Our engineers are investigating the issue and we apologise for the inconvenience caused. We will provide further updates as soon as possible.
Posted Feb 28, 2020 - 15:34 CET
This incident affected: SOFORT.