We are currently having issues with purchase visualizations in the Klarna App EU
Incident Report for Klarna
Resolved
This incident has been resolved. We apologize for any inconvenience caused.
Posted Oct 24, 2021 - 21:54 CEST
Identified
The issue has been identified and we are working on restoring services as soon as possible.
Posted Oct 24, 2021 - 21:41 CEST