Payment and order handling functionalities degraded in the Klarna App
Incident Report for Klarna
Resolved
Our systems have gone back to normal. The incident is resolved.
Posted Dec 11, 2019 - 13:50 CET
Investigating
Customers in the EU region, excluding UK, might experience degraded performance with functionalities in the Klarna App:

Accounts cannot be seen and therefore, also the related payment- and order functionalities such as slice it, snooze and paying invoices are not possible to handle. Our engineers are investigating the issue and we apologize for the inconvenience. We will provide further updates as soon as possible.
Posted Dec 11, 2019 - 12:32 CET
This incident affected: Klarna App.