Customer service delays due to issues with internal tooling
Incident Report for Klarna
Resolved
This incident has been resolved. We apologize for the inconvenience.
Posted Nov 19, 2021 - 15:18 CET
Identified
We are currently experiencing issues with an internal tool and that is impacting customer service's ability to support our customers. The issue has been identified and we are currently working on a fix.
Posted Nov 19, 2021 - 15:02 CET
This incident affected: Support (Europe).