Delay in processing payments for some weekly settlement merchants in the EU region
Incident Report for Klarna
Resolved
All delayed weekly settlement reports will be processed today.
Posted May 03, 2021 - 08:30 CEST
Monitoring
Due to technical issues, we failed to process payments for some weekly settlement merchants in the EU region. All missing payouts will be processed before the end of Monday next week. We apologize for the inconvenience caused.
Posted Apr 29, 2021 - 08:45 CEST