Disruption to merchant support via email
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Apr 23, 2020 - 17:09 CEST
Identified
Email service on merchant@klarna.se and ms.se.inhouse@klarna.se have resumed. If you are using kundensupport@klarna.de to communicate with us however there are still some disturbances that we are working to resolve. In the meantime, we recommend affected merchants contact us via telephone through the contact numbers listed on https://www.klarna.com.
Posted Apr 23, 2020 - 14:48 CEST
Investigating
Some merchants in contact with our support team are currently not receiving emails that we send them. We apologize if you are affected by this and we are working to fix the problem as soon as possible. In the meantime, we recommend merchants contact us via telephone through the contact numbers listed on https://www.klarna.com.
Posted Apr 23, 2020 - 11:15 CEST
This incident affected: Customer Service.