We are currently experiencing failing iDEAL payments through ING bank
Incident Report for Klarna
Resolved
This incident is now resolved. We apologize for any inconveniences.
Posted Jul 24, 2019 - 12:11 CEST
Update
We are continuing to investigate this issue.
Posted Jul 24, 2019 - 12:07 CEST
Investigating
A large amount of iDEAL payments are failing since the ING bank is currently not available. Customers, therefore, are not able to pay using that bank with iDEAL.
Our engineers and the bank are already working on a solution.
Posted Jul 24, 2019 - 12:00 CEST
This incident affected: Klarna App, Klarna Checkout (KCO), and Klarna Payments (KP) Frontend.