~95% of new customers trying to sign up for the Klarna Card, Klarna OTC in the EU are getting errors.
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted May 01, 2021 - 13:25 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 01, 2021 - 12:59 CEST
Identified
New customers trying to sign up for the Klarna Card in the EU are getting errors due to 3rd party issues. Technical teams are investigating the issue. We apologize for the inconvenience.
Posted May 01, 2021 - 12:37 CEST