We are experiencing issues with purchases in the US
Incident Report for Klarna
Resolved
The issue is resolved. We are back to normal operation.
Posted Oct 15, 2019 - 11:34 CEST
Identified
We are currently experiencing issues with purchases in the US and are working on a solution.
Posted Oct 15, 2019 - 11:04 CEST
This incident affected: Klarna Checkout (KCO).