Klarna Loans UK Customer Service main number unreachable
Incident Report for Klarna
Resolved
This incident has been resolved since 14:12 CEST.
Posted May 07, 2020 - 15:57 CEST
Investigating
Klarna Loans customers are currently not able to reach Customer Service via the main phone number 0333 321 6080, instead they can be reached using 0203 005 0810.

Our carrier is investigating the issue and we apologize for the inconvenience caused. We will provide further updates as soon as possible.
Posted May 07, 2020 - 11:13 CEST