Degradation in performance for Klarna Payments through PayBright in Canada
Incident Report for Klarna
Resolved
This issue has been been resolved by PayBright, orders are flowing normally.
Posted Jun 07, 2021 - 22:48 CEST
Update
We are working with the vendor to get this issue corrected.
Posted Jun 07, 2021 - 16:58 CEST
Update
We are continuing to investigate this issue.
Posted Jun 07, 2021 - 13:21 CEST
Update
We are continuing to investigate this issue.
Posted Jun 07, 2021 - 08:48 CEST
Investigating
Klarna payments in Canada through PayBright is experiencing a degradation in performance. We are currently investigating the situation.
Posted Jun 07, 2021 - 05:01 CEST
This incident affected: Klarna Payments (KP).