Degraded performance for Pay in Parts in the EU.
Incident Report for Klarna
Resolved
This incident has been resolved. We apologize for any inconvenience this may have caused.
Posted Jan 05, 2021 - 18:45 CET
Investigating
We are currently investigating the issue. We apologize for any inconvenience.
Posted Jan 05, 2021 - 18:22 CET
This incident affected: Klarna Payments (KP).