Service Provider Outage Causing Problems With Payments and Card Creation
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Jul 28, 2021 - 23:16 CEST
Monitoring
An outage with Visa has caused issues for customers attempting to purchase items using Visa cards or creating new cards in the Klarna app. Visa is reporting this has been resolved and we are monitoring the issue.
Posted Jul 28, 2021 - 22:48 CEST