Consumers in Belgium may have trouble paying invoices in the Klarna App
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Nov 17, 2021 - 11:47 CET
Identified
This is caused by a 3rd party provider and more information regarding the status can be found here: https://status.mollie.com/incidents/1qv0qqcgksx7
Posted Nov 17, 2021 - 11:10 CET
This incident affected: Klarna App (Europe).