Klarna Browser Extension degradation
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Nov 17, 2022 - 13:45 CET
Update
We are currently experiencing issues with the Klarna Browser Extension. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Nov 17, 2022 - 12:49 CET
Investigating
We are currently experiencing issues with the Klarna Browser Extension. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Nov 17, 2022 - 11:40 CET
This incident affected: Purchase API (Europe, North America, Asia Pacific).