Issue with converting from pay-later to Slice-it payment method
Incident Report for Klarna
Resolved
The issue is resolved. We are back to normal operation.
Posted 18 days ago. Sep 27, 2019 - 11:23 CEST
Investigating
We are having issue with processing Pay-later to Slice-it conversion service. Users maybe rejected during conversion. Our engineering team is working on the issue. We are sorry about the inconvenience.
Posted 18 days ago. Sep 27, 2019 - 11:11 CEST