H&M customers in Switzerland might have received malformed emails
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted 26 days ago. Aug 22, 2019 - 16:37 CEST
Investigating
Currently we are experiencing an issue affecting H&M in Switzerland, where customers might have received malformed emails. Our engineers are working on correcting this, and we apologise for the inconvenience.
Posted 26 days ago. Aug 22, 2019 - 15:36 CEST
This incident affected: BillPay.