New customers in the US and UK are currently unable to sign up for Klarna User Accounts through the Merchant Purchase Flows
Incident Report for Klarna
Resolved
This incident has been resolved at 16:38 CEST.
Posted May 31, 2021 - 16:46 CEST
Investigating
We are currently investigating the issue.
Posted May 31, 2021 - 16:05 CEST