Sofort Unavailable
Incident Report for Klarna
Resolved
The issue is now resolved.
Posted May 25, 2020 - 15:34 CEST
Investigating
We are aware that it is not currently possible to make payments using Sofort. We are investigating the issue and apologize for the inconvenience caused.
Posted May 25, 2020 - 14:37 CEST