Merchant Portal degradation for UK merchants
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted May 16, 2022 - 11:21 CEST
Investigating
We are currently experiencing a degradation of Merchant Portal for the UK, merchants are currently unable to create support tickets. We are working to restore the service as soon as possible. Thank you for your patience.
Posted May 16, 2022 - 09:47 CEST
This incident affected: Merchant Operations (Europe).