Disputes in Klarna App degradation.
Incident Report for Klarna
Resolved
We are continuing to investigate this issue.
Posted Sep 16, 2022 - 14:00 CEST
Update
We are continuing to investigate this issue.
Posted Sep 16, 2022 - 13:48 CEST
Investigating
We are currently experiencing a degradation of Disputes in Klarna App in the EU. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Sep 16, 2022 - 13:43 CEST
This incident affected: Klarna App (Europe).