Payment method Slice it in the UK is degraded since 01:45 CEST for ~1% of consumers
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Jun 04, 2021 - 02:01 CEST
Investigating
We are currently investigating this issue.
Posted Jun 04, 2021 - 02:01 CEST
This incident affected: Klarna Payment Methods (KPM).