Merchant invoices can not be visualized in Klarna Online
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Aug 30, 2021 - 20:06 CEST
Identified
Technical teams have found an issue with a recently introduced change and are working on correcting at this time. We apologize for the inconvenience.
Posted Aug 30, 2021 - 18:59 CEST
This incident affected: Klarna Online.