New merchants in Italy may currently receive an error message when trying to onboard
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Sep 29, 2021 - 14:18 CEST
Investigating
We are currently investigating the problem and will provide further updates as soon as possible.
Posted Sep 29, 2021 - 13:45 CEST