US merchants may experiencing lower volume due to SMS delivery issue
Incident Report for Klarna
Resolved
Problem is resolved and normal service is resumed. We thank you for your patience and apologize for the inconvenience caused.
Posted Jun 16, 2020 - 08:48 CEST
Investigating
Some merchants in US are currently experiencing lower traffic amount due to slow SMS delivery. We have confirmed that the issue is on the SMS provider side. We will follow up with the provider and provide further updates as soon as possible.
Posted Jun 15, 2020 - 21:50 CEST
This incident affected: Klarna Payments (KP).