EU Klarna Card users affected by 3D Secure issues
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Apr 17, 2020 - 15:50 CEST
Investigating
Consumers in the EU are currently experiencing difficulties with the 3D-Secure flow on their Klarna Cards. If a 3D-Secure validation is triggered they will be unable to complete their purchases. Our engineers are investigating the issue and we apologize for the inconvenience caused. We will provide further updates as soon as possible.
Posted Apr 17, 2020 - 15:44 CEST
This incident affected: Klarna Card.