Degraded Performance of BillPay Backoffice
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Nov 22, 2019 - 11:39 CET
Identified
Merchants in the DACH region may encounter problems using the Billpay Backoffice service at this time. Our engineers are working to fix the issue and we will share further updates as soon as possible.
Posted Nov 22, 2019 - 10:40 CET
This incident affected: BillPay.