klarna.com/demo is currently unavailable
Incident Report for Klarna
Resolved
This issue has been resolved. We apologize for the inconvenience.
Posted Jan 22, 2021 - 15:48 CET
Investigating
The demo web page www.klarna.com/demo is currently unavailable
Posted Jan 22, 2021 - 13:47 CET
This incident affected: Demo services.