~99% of consumers in the EU are currently unable to create a one time card or to sign up for a Klarna Card.
Incident Report for Klarna
Resolved
This has now been resolved and we are back to normal operation since 12:33 CET.
Posted May 20, 2021 - 13:23 CEST
Update
We are again seeing a degradation of service impacting both creating a one-time card or sign up for a Klarna Card.
Posted May 20, 2021 - 10:51 CEST
Update
Our technical team has confirmed that creating cards is now operational, still some degradation in viewing card details.
Posted May 20, 2021 - 10:35 CEST
Identified
Consumers in the EU are not able to create a one-time card (due to issues at 3rd party provider Evry).
Posted May 20, 2021 - 09:22 CEST
This incident affected: Klarna Card.