Issues with customer and merchant service phone lines
Incident Report for Klarna
Resolved
This incident has been resolved. We are still waiting for an update from the carrier, but the phone lines are currently working.
Posted May 04, 2021 - 11:48 CEST
Update
This is currently impacting phone lines in Norway, Belgium, and Denmark. All these phone lines are currently unreachable and we request you to either call us later or use our chat service.
Posted May 04, 2021 - 10:54 CEST
Investigating
Due to technical issues, it can be difficult to reach our consumer/merchant service by phone. We are working on solving this issue as soon as possible and apologize for any inconvenience caused in the meantime. We kindly request that you contact us through chat instead.
Posted May 04, 2021 - 10:38 CEST