Klarna App degradation
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Jun 10, 2022 - 07:04 CEST
Identified
The issue has been identified as being related to an external provider. We continue to see low levels of error rates on some Klarna App features.
Posted Jun 10, 2022 - 06:34 CEST
Investigating
We are currently experiencing issues with the Klarna App in the US and Canada. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Jun 10, 2022 - 05:50 CEST