Merchants in the EU may currently receive an error message when trying to update profile details
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Jul 27, 2021 - 15:45 CEST
Investigating
We are currently investigating the problem and will provide further updates as soon as possible.
Posted Jul 27, 2021 - 15:27 CEST