Customers in Germany not able to add Klarna card to Google Pay
Incident Report for Klarna
Resolved
Our third party provider have now deployed a fix and this incident is considered resolved. Thanks for your patience.
Posted 2 months ago. Jun 14, 2019 - 10:41 CEST
Investigating
Customers in Germany are currently unable to add their Klarna card to Google Pay. Our engineers are investigating the issue, and we apologise for the inconvenience.
Posted 2 months ago. Jun 13, 2019 - 11:00 CEST
This incident affected: Klarna Card.