KP not loading in Internet Explorer
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted 27 days ago. Nov 13, 2018 - 16:56 CET
Identified
The issue has been identified and a fix is being implemented.
Posted 27 days ago. Nov 13, 2018 - 16:48 CET
This incident affected: KP.