Internet Disruption in Sweden
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Sep 12, 2019 - 15:26 CEST
Identified
We are currently aware of and monitoring disruptions to internet service providers in Sweden, which may consequently be affecting incoming orders for merchants in the region.
Posted Sep 12, 2019 - 12:43 CEST