Failing transactions for the Pay in 3 service in the UK
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Apr 01, 2021 - 13:22 CEST
Identified
10% of Pay in 3 service in the UK is failing due to technical issues with 3rd party.
Technical teams are investigating the issue.
Posted Apr 01, 2021 - 11:01 CEST
This incident affected: Klarna Payment Methods (KPM).