Problems with MFT for US Merchants
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted about 2 months ago. Apr 01, 2019 - 20:30 CEST
Identified
File restore is under way.
Posted about 2 months ago. Apr 01, 2019 - 20:09 CEST
Investigating
The MFT service is currently down for US Merchants. Investigation is ongoing.
Posted about 2 months ago. Apr 01, 2019 - 18:37 CEST