Klarna.se website is having intermittent issues
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Jan 27, 2021 - 12:30 CET
Investigating
The klarna.se website is having intermittent issues. Our engineers are already working on fixing the issue. Please use klarna.com instead.
We will provide further information as soon as we can and apologize for every inconvenience.
Posted Jan 27, 2021 - 12:22 CET
This incident affected: Klarna Website.