We are experiencing disturbances with the system, affecting primarily Klarna Checkout.
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted May 10, 2015 - 22:29 CEST
Monitoring
We have applied the fix and all systems are working fine.
Posted May 10, 2015 - 22:14 CEST
Identified
The root cause has been identified, we are working on resolution now.
Posted May 10, 2015 - 21:09 CEST
Investigating
We are experiencing disturbances with the system, affecting primarily Klarna Checkout. We are investigating and will come back with more information.
Posted May 10, 2015 - 20:38 CEST