Issue with Checkout Purchases in UK
Incident Report for Klarna
Resolved
Problem with Checkout Purchases in UK is now resolved and services are all working flawlessly again.
Posted Nov 30, 2015 - 01:40 CET
Identified
We are experiencing some issues with Checkout Purchases in UK at the moment and our technical staff is working to resolve it as soon as possible.
Posted Nov 30, 2015 - 01:26 CET