Issues with phone system
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Aug 22, 2016 - 14:36 CEST
Investigating
Currently there are issues with Klarna’s phone system. We’re investigating the cause of this issue.
Posted Aug 22, 2016 - 12:30 CEST