Merchant GUI issue in Nordic and DACH countries
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted about 1 month ago. Jun 21, 2017 - 13:28 CEST
Investigating
We are currently experiencing an issue with Klarna Online in the live environment. We are investigating the issue.
Posted about 1 month ago. Jun 21, 2017 - 13:25 CEST
This incident affected: Klarna Online.