Not possible to pay with AMEX at the moment
Incident Report for Klarna
Resolved
Issue has been resolved since 23:15.
Posted 3 months ago. May 10, 2017 - 23:55 CEST
Identified
AMEX payments have been unavailable in UK, NL, DACH, and Nordics since 21:26. Waiting for external provider for more information.
Posted 3 months ago. May 10, 2017 - 22:44 CEST