Problems with card purchases
Incident Report for Klarna
Resolved
This incident has been resolved since 19:25.
Posted Jul 14, 2016 - 19:44 CEST
Investigating
At the moment a small percentage of credit card purchases fail.
Posted Jul 14, 2016 - 19:03 CEST