Minor disturbances in Klarna Checkout affecting Google Chrome on iOS devices
Incident Report for Klarna
Resolved
The issue has been tracked down and resolved.
Posted Jul 17, 2014 - 17:41 CEST
Identified
Yesterday we detected an issue for a limited number of customers using Chrome on iOS devices. The issue affects customers who updated Chrome with the update pushed by Google on July 15. The issue will be solved during the day.
Posted Jul 17, 2014 - 12:50 CEST