We are experiencing disturbance in Klarna Checkout
Incident Report for Klarna
Resolved
The issue has been tracked down and resolved. We are back to normal operation on Klarna Checkout.
Posted Aug 23, 2014 - 17:30 CEST
Identified
We have identified the cause of the problem and working on a fix of it.
Posted Aug 23, 2014 - 16:42 CEST
Investigating
We are experiencing disturbance in Klarna Checkout. We are working on it.
Posted Aug 23, 2014 - 16:22 CEST